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Introduction 
Datastream Advance provides current and historical time series data on stocks, stock indices, bonds, futures, interest rates, commodities, 
derivatives, exchange rates, and economic data. 
Scope 
Global coverage in contents. Depending on the series, most market data is available on a daily basis; and most economic data is 
available monthly or quarterly. 
Access 

 Available at Doriot and Tanoto Libraries 
 Login to the computer and double-click the Datastream icon  

Features 
 Results easily downloadable to Excel, Word, or PowerPoint 
 Simplified search for data series and datatypes through Navigator 
 Interactive Charting and Help Browse for data series mnemonics search tools in Navigator 
 Excel add-in Datastream-AFO (Advance for Office) for running complex searches directly in Excel 

 
 Help 
 Click the Help from the top menu bar on any page 
 For search assistance, ask a librarian at the Information Desk 

Searching Datastream Advance 
Datastream Advance interface is divided into distinctive areas as shown on the figure below, where you set your selections and run 
searches. The output results come in report, graph, or data format depending on your preference and type of values. The key feature for 
data searching in Advance 4.0 is the Navigator accessible from  the Navigator button. 
 

 

Output window   Data series area 
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Search Datastream Advance in four quick steps: 
Step 1: Select category and click the  Navigator button to choose category series in the Data Categories area 
Step 2: From the icon bar, select format for your output results and choose report type for your series in the Data Series area 
Step 3: Refine your selections by setting dates, frequency, datatype, and currency as applicable in the Settings area.  

 Choose datatype if applicable for times series requests by clicking  the Datatype Navigator button in the  
 Datatype Setup area 

Step 4: Run search by clicking the Run Now button and view results in the Output window 
 Save, download results to the appropriate Microsoft office program: Excel, Word, PowerPoint 

Data categories area 

  Settings area
Navigator button 

Datatype 
Navigator button Datatype setup area for 

times series requests 

http://www.gsb.stanford.edu/library/feedback_guide.html
mailto:Jackson-infodesk@gsb.stanford.edu
mailto:rcrc-action@gsb.stanford.edu


Step 1: Selecting a category and choosing a category series 
Datastream series is a particular set of financial data over time, e.g. company equities, bonds, indices etc. All Datastream series are 
grouped into the following 15 data categories accessible from the Category drop down list: Equities • Equity Indices • Constituent Lists • 
Unit Trust • Investment Trusts • Bonds & Convertibles • Bond Indices • Warrants • Economics • Economic Reports/Charts • Exchange 
Rates • Interest Rates • Futures • Options • Commodities. 
 

 

Select category here 

Enter search string here 
Click here when you search by 
data series mnemonic and when 
you search for dead companies 
series 

Click the Navigator 
here to start search  

Click on this link to 
search for data series 
from previous requests 

Click the Datatype Navigator 
here for Time Series requests

 
By selecting a category, you gain access to all data series stored within that category. You have the following options to select data 
series: 
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 Using Navigator: 
Navigator Quick Search- enter a keyword in a Series box and click the , then 
click on DS Mnemonic or DS code link from the list of matching entries 
 

Navigator Power Search-click on the  Navigator button and enter your criteria 
in the available fields as shown on the figure on the right. Click the  button to 
select series from the list when available. 
 

Navigator Drill Search-click on the Drilldown link on top menu bar and find data 
series through the menu-driven method 

 Using Datastream mnemonic 
Click the Expert entry check box, and enter the mnemonic in the Series box  

 Using Recent Series search 
Click the Recent Series and select data series from the drop down list of your previous requests 

Click here to select data 
series from the menus

Change category here 

Step 2: Selecting format for output data and selecting data request 
In the Data Series area, select the format of your output data and then select a report or request type from the list. Depending on the 
category, the output format tabs and the contents in the data series window will differ.  
 

 

Click on one of the tabs here to 
select format for output report

Choose report or 
data request type 
here  

 

 
− Overview on a single series. Select report from the 

list of preformatted reports available for most of the data 
categories: equity, commodity, warrant, trust, and bonds from 
different sources, e.g. Thomson, I/B/E/S etc. 
 

− Chart of a single series. Select from the list 
of available charts, e.g. Line chart, Moving Average 
Chart, Price and Volume Chart etc. 
 

− Report on a single series. Select from the list of 
preformatted reports. Reports are different for different 
categories. 
 

− Data for a single series (in spreadsheet format). 
Select time series, static data, and company accounts data 
reports. Customize reports with additional criteria. All reports 
can be exported to Excel spreadsheet. 
 

− Summary for list of series. This format is available 
only for list categories such as Constituents and Local lists. Values 
for Datastream constituents are displayed in one summary report, 
or as a chart, or as a data report depending on category series. 
 

− Find company mnemonics. Use this function to 
search for mnemonics for both “live” and “dead” stocks held in 
Datastream.  Remember to check the Expert Entry box. 
 

− Comparison-one or more series. Create reports on 
multiple series and compare across different data categories e.g. 
compare a company’s performance against an index.  
 



Step 3: Refine selections by setting dates, datatype, frequency, currency in the Settings area 
In the Settings area, you can refine your request by selecting frequency, dates, datatype, and currency as applied to your data series. 
NOTE: The contents of the Settings will be different for different data series and output formats. 
 
 Frequency: Click the Settings to set up frequency for Time Series data (daily, weekly, monthly, quarterly, or yearly).  
 Dates: Select time period by one of the following options: by relative dates (-1Y, -10Y, -6M etc.), or click the  and enter a fixed 

date or a date range.  
 

 

Click here to select 
frequency for time series 
data, e.g. daily, weekly etc. 
For static requests, select 
datatype here. 

Click here to run request 

Click here to select a fixed 
date or range of dates 

Click in a circle to select 
relative dates, e.g. latest 
year, last 6 months (-6M) 

 

 Datatype: Find datatype for your series using the Datatype Navigator. When you create a request for Time Series data, click the  
Datatype Navigator button in the lower left area of the screen. For Static data requests, click the   and then click the Datatype 
Navigator button to open a Datatype Search screen similar to the one shown on the right. 

 
Datatypes are grouped by their types and sources, e.g. from the drop 
down list in the Type box you can select Static or Time Series; in the 
Group box, you can select Key Datatypes, or MSCI, or Datastream 
etc. To broaden you search, select All in both or either category. In 
addition, you can use the drop down lists in the Find section of the 
screen. Enter the name or the code (depending on your setting) in the 
Find text box.  
 
Once you have specified your search criteria, click the Search. To add 
datatype to your request, click on the mnemonic link from the list of 
matching entries. You can select up to nine datatypes for each request. 
 Click on the mnemonic 

link to add datatype to 
your request 

 Currency: Select currency from the drop down list in the Currency box 

Step 4: Running requests and obtaining results. 
After you select data series in the Data Series window and add settings if applicable, click the  located in the Settings Area. Your 
search results: graphs, reports, or data will open in the Output window as shown below.  
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You can resize the window by clicking the arrow in the lower right corner. 
You can also add annotations to your data report (highlight text, insert comments, arrows etc.) before you save your report in Word or 
PowerPoint. To display/hide Annotations toolbar, click the   icon from the top icon toolbar. 
 
Saving and exporting results: Click the icons from the top icon bar to export results to Excel or to save results as file. To save results 
in Excel, Word, or PowerPoint using the top menu, select Tools>Transfer> Excel (or Word or Powerpoint) 

Click here to maximize or 
minimize window 

Click this icon to save in Excel 

Click here to display/hide 
Annotations toolbar

 



Using the Request Table 
If you need to transfer large amounts of data from Datastream once or on a regular basis for the same series, you can use the Request 
Table feature to create batches of refreshable data requests. You will need to use the Advance For Office (AFO) template built in Excel. 
To run the Request Table, follow these steps: 
1. Open Excel. In a spreadsheet, enter tickers in a column, starting with A1. NOTE:  Remember to use the Datastream equity prefix 

codes; find companies’ prefix codes in the Mnemonic column under the Equity category, e.g. U:IBM, ‘@SNDK.  
Enter @ prefix in Excel cell as text, e.g. with preceding single or double quotation marks. 

2. At top of spreadsheet, under Datastream AFO, select Tools > Create List. NOTE:  Make sure the cursor is in A1. 
3. In the pop-up window, click on Change Selection. 
4. Highlight all tickers needed. Click OK in window. 
5. Under List File Name, create a name with suffix .llt . 
6. Click OK.  Window will tell you it's been successfully created. 
7. Click OK.  Save the spreadsheet and give it a name.  
8. In a new spreadsheet, select Datastream AFO > Request Table > New Request Table. 
9. Enter designation at top of each column as suggested below. For definitions of available data formats, click the red arrow in the top 

right corner of each column. Enter designations respectively as follows: 
 In Update column, type YES  
 Select Request Type, e.g. TSL  
 Select Format, e.g. RCH  
 Enter the name of your list (see above) in Series Lookup or click the right icon to select from the list 
 For Datatype, leave blank for default (stock price), or enter appropriate Datatype  
 Enter Dates  
 Enter Frequency, e.g. Daily  

10. Position the cursor in top empty cell under Data Destination.  
11. Click Data Destination box. A popup Create Destination Reference window opens. NOTE: Do not close the window and proceed.  
12. Select Window from the top menu.  
13. Find your saved spreadsheet, and click on it.  
14. Put cursor in cell A1 on the spreadsheet.  
15. Click OK on the popup window; file location will now appear in the popup window under Data Destination.  
16. Click Process Table.  Requested data will appear in your spreadsheet. 

Searching Tips: 
 Search terms are not case sensitive 
 For data series with a term less than one year, e.g. 90-dayTreasury Bills, use category Interest Rate; for data categories with a 

term over one year, use category Bond indices, e.g. Us Government Bond Series 10 Year 
 Use Help Browse link on the Navigator screen to search for datatype mnemonic. Alternately, can use top menu option: 

View>Diagnostics>Show Interactive Terminal. At the prompt, enter HELP <Enter> 

Sample Searches 

Historical Stock Prices: Find the daily stock price for Genentech for the past 5 years. 
1. In Category, select the Equities. Enter genentech in the Series box. Click the Navigator button. 
2. Click the D:GT6 (DS mnemonic) from the series list. 
3. Click the Data format tab (spreadsheet) and highlight Time Series Data. 
4. Click the Settings button. Move the frequency bar to daily. Click OK. 
5. Select –5Y to get the daily rate for the last 5 years. 
6. Click the Run Now. The results will display in the Output Window. 
7. View, print or export the results. 

Dead companies information: Find the prices for companies no longer traded. 
1. In Category, select Equities. Click the Expert entry check box. 
2. Enter dead company’s name or part of the name in the Series box and click the Find tab (flashlight).  
3. Highlight the Datastream Remote Search-Dead series. Click the Run Now. 
4. In the Output window, click on the name of the company. NOTE: View which data is available for a dead series. 
5. Click the Data format tab (spreadsheet) and highlight Time Series Data. 
6. Click the Run Now. The results will display in the Output Window. 
7. View, print or export the results. 

Economic Data using Advance for Office (AFO) for downloading multiple series: Find daily rates for 90-day Treasury Bill, Fed 
Funds, and 6-month LIBOR for the past year. 
1. Open Excel. On the top menu, click the Datastream-AFO and select Time Series Request. 
2. Enter –1Y in Start date, select Daily in Freq[uency]; click the following options:  Row Titles, Col Titles, Headings, Currency, Embed, 

and Visible Button as applied. 
3. Click the Navigator button. On the Navigator screen, in Categories, select Interest rates. 
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4. On top of the navigator screen click on the Help Browse link. The Help menu screen will open. NOTE: Click the Home at the 
bottom of the screen if the first page is not displayed. 

5. Follow the menu choices to find data series mnemonics. For example, to find the 90-day Treasury Bill mnemonic, do the following: 
 From the main menu, double click option 2 under National Interest Rates; double click 25 for USA; scroll down the screen to 

Interest rates: United States Government securities: Treasury bills, secondary market, discount basis category and 
double click FRTBS3M mnemonic for 90 days (3 months) T-bills. 

 Once you’ve selected the mnemonic, it will appear in the box at the bottom of the screen. Click the Finish. Data will 
automatically populate the Excel spreadsheet. 

6. Position your cursor in the free cell and repeat the same process as described in the previous step for Fed Funds rate (USFEDFD), 
and 6-month LIBOR (BBUSD6M). 

7. View, print or save the results. 
NOTE: If you know the mnemonics for your data series you can enter the mnemonic codes, separated by a comma, e.g. (USTBL3M, 
USFEDFD, BBUSD6M), then click the Submit. 
8. Click the Refresh button (cell A1) to obtain the latest rates. 

Exchange Rates: Find the daily exchange rates between Indian Rupee and U.S. Dollar for the past year. 
1. In Category, select Exchange rates. Enter Indian in the Series box. Click the Navigator button. 
2. Click the USINDNR mnemonic for Indian Rupee to US$ from the series list. 
3. Click the Data format tab (spreadsheet) and highlight Time Series Data. 
4. Click the Settings button and move the frequency bar to daily. Click OK. 
5. Select –1Y to get the daily data for the past year. 
6. Click the Run Now. The result will appear in the Output Window. 
7. View, print or export the results. 

Commodity Prices: Find weekly prices for shelled almonds for the past 90 days.  
1. In Category, select Commodities. Enter almond in the Series box. Click the Navigator button. 
2. Click the ALMUSSS mnemonic for Almonds Shelled US Standard Run from the series list. 
3. Click the Data format tab (spreadsheet) and highlight Time Series Data. 
4. Click the Settings button and move the frequency bar to weekly. Click OK. 
5. Select –3M to get the weekly data for the last 90 days.  
6. Click the Run Now. The result will appear in the Output Window. 
7. View, print or export the results. 

Compare One or More Data Series. Display a comparison chart or Genentech and GlaxoSmithKine. 
1. Select the Comparison-one or more series tab and highlight the Comparison Line Chart (rebased).  
2. In Category, select Equities. Enter genentech in the Series box. Click the Navigator button. 
3. Click the U:DNA mnemonic from the series list. 
4. Click the + button to add the first company to your list. 
5. Repeat steps 2-3 for GlaxoSmithKline. 
6. Click the –5Y button. Click the Run Now. The result will appear in the Output Window. 
7. View, print or export the results. 

Index Performance Report: Find the dividend yield and the market value for the FTSE100. 
1. In Category, select Constituent lists. Enter ftse 100 in the Series box. Click the Navigator button. 
2. Click the LFTSE100 mnemonic for FTSE100 Constituents from the series list. 
3. Click the Summary for lists of series tab and highlight Static Data. 
4. Click the Settings. Click the Datatype Navigator button .  
5. In Type, select All; in Group select Key Datatypes; in Find, select Name-Contains and enter dividend in the text box. Click the 

Search. 
6. Click the DY mnemonic for Dividend yield. 
7. Repeat steps 4-6 for market value. Click OK. 
8. Click the Run Now. 
9. View, print or export the results. 
Print/Download 
With search results displayed in the Data Output window, you can print or download your output results 
 To print output results: Select File > Print from the top menu bar. 
 To save results in Excel, Word, or PowerPoint: Click the Excel icon from the toolbar , or from the top menu, select Tools > 

Export, or select Tools > Transfer > Excel (or Word or Powerpoint) 
Documentation 
 Datastream Online Manual and Tutorial can be accessed from the Help button. 

 
Updated: 4/21/2006 
This guide was adapted with permission from Stanford Library. 
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